Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: help? Speedo sending module fried

  1. #1

    help? Speedo sending module fried

    So, Had some electrical issues lately on my M12 GTO 3R, 99% of which are now all resolved, and many of which are improved and better than ever!

    The final remaining issue is the speedo. The speedo doesn't work at all. And through some troubleshooting here, we believe it's due to the sending unit in the front hub being bad. (the LED doesn't come on on it) Having a real problem figuring out what it is and sourcing one to replace it though.

    Does anyone know for sure if it's the same as the Rossion Q1 uses still? Does anyone have a source for one? Can anyone help? heh

    Currently I'm just using a Garmin as my speedo, but I really wanna make the real one work again. We have already replaced the actual gauge.

    Thanks!
    -Nathan

  2. #2
    Join Date
    Dec 2011
    Location
    Santa Ana, Cal.
    Posts
    1,126
    The exact same thing happened to my car, and it was as you suspect, the sending unit. Turbohoses fixed mine. So you may want to call them to get the parts.

  3. #3
    Thanks. I may try to give them a call this week. Hopefully Hoover and crew have the answer!

  4. #4
    Interesting. On my newly acquired car I might have the same thing. Speedometer was fine on way to safety inspection. Inspector said it wasn't working
    Odd. But on way home it was indeed not working. But it sputtered to life halfway home but only for a couple of miles. Then it died again. What's the troubleshooting algorithm for this?

  5. #5
    Couple things that tweaked my speedo long ago. M12 version.

    Right front is the sending unit. Make sure all the leads are solidly attached and not shorting.
    Also had some weird electronic things happen when the passenger foot well fuse box got damp. I think it was A/C condensation not clearing.

    Both fixed by the installer soon after I got the car so hard to remember.

  6. #6
    I admit. I got tired of chasing mine. (Worked good below about 70deg, nothing above that temp).

    Coped out and put in a speedhut GPS speedometer . Solved the issue.

    If you ask nicely, they even set the odometer to your existing millage

  7. #7
    Yes, the odometer stopped working when the speedo stopped working. Also what is the little rubber nubbin at the 6 o'clock position for?

  8. #8
    Join Date
    Mar 2015
    Location
    South East United States
    Posts
    87
    Should be the button to switch from odometer to trip odometer. Press and hold to clear the trip meter back to zero IIRC.

  9. #9
    Join Date
    Dec 2011
    Location
    California
    Posts
    104
    Speedo problems usually are due to one of two things - the speedo sensor is bad (usually the wire to the sensor is broken somewhere), or the speedo sensor isn't reading the toothed wheel properly.

    I'd start by checking the sensor. Jack up the car so the right front wheel is off the ground (be sure to properly support the car on jack stands, etc.) and spin the wheel until the speedo sensor is pointing towards a gap in the toothed wheel. Turn the key to the "run" position and turn off the alarm. Gently place the tip of a screwdriver over the tip of the speedo sensor - the light at the base of the sensor should turn on, and turn off when you remove the screwdriver.

    If the sensor works, check the toothed wheel for dirt, or bent teeth. Clean both the toothed wheel, and the sensor - make sure there isn't any debris on the tip of the sensor. Try adjusting the sensor closer to the wheel. If everything is ok, the light at the base of the sensor should flash when you spin the wheel.

  10. #10
    Thanks for the tips Jimbo!
    I lost my speedo last time at T-hill. Next thing I see...

    ImageUploadedByTapatalk1444275853.031893.jpg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •